1. Этот сайт использует файлы cookie. Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie. Узнать больше.
  2. Вступайте в наш Telegram чат: https://t.me/a_parser Нас уже 2200+ и мы растем!
    Скрыть объявление

aparser+puppeteer+linux=Missing X server or $DISPLAY

Тема в разделе "Задачи", создана пользователем NØХ, 9 авг 2022.

  1. NØХ

    NØХ New Member

    Регистрация:
    9 авг 2022
    Сообщения:
    2
    Симпатии:
    0
    использование: HTML::EmailExtractor, HTML:LinkExtractor
    опция: Engine - Chrome

    В ноду не передаются env DISPLAY, соответственно хром не понимает куда ему подключатся для вывода картинки в итоге получаем ошибку "Missing X server or $DISPLAY". ENV в родительском процессе - ОК.

    Плюс проблема допом под виндой с тойже таской: после выполнения окна хрома не закрываются автоматически.
     
  2. Forbidden

    Forbidden Administrator
    Команда форума A-Parser Enterprise

    Регистрация:
    9 мар 2013
    Сообщения:
    3.334
    Симпатии:
    1.784
    проверьте наличие переменной DISPLAY на версии 1.2.1614
     
  3. Support

    Support Administrator
    Команда форума A-Parser Enterprise

    Регистрация:
    16 мар 2012
    Сообщения:
    3.919
    Симпатии:
    1.984
    Опишите подробнее при каких обстоятельствах это происходит, при необходимости пришлите пресет и запросы.
     
  4. NØХ

    NØХ New Member

    Регистрация:
    9 авг 2022
    Сообщения:
    2
    Симпатии:
    0
    Благодарю, в бете эти проблемы отсутствуют.
     
    #4 NØХ, 9 авг 2022
    Последнее редактирование: 9 авг 2022

Поделиться этой страницей